Friday, April 11, 2014

Install latest patch of APEX 4.2 (4.2.5)

A few days ago Oracle brought out a new patch for APEX 4.2, this will be the latest version of this build, the next version of APEX will be 5.0.

If you already have APEX 4.2.x installed you can download a patch from support.oracle.com, the patch number is 17966818.

If you have an earlier version of APEX you can download the full version of APEX and install that.

As with other patch sets, this one is not different; it includes some bug fixes, updates in the packaged apps and the introduction of some new apps. You find the full patch set notes here.

Installing the patch in my APEX 4.2.4 environment took less than 15 minutes and everything went fine. 


I recommend everybody moving to the latest version as this is the final build of APEX 4.2.

Update 16-APR-2014: we actually hit one issue, which was fixed by Oracle today. So I would install this additional patch too. In support.oracle.com search for Patch 18609856: APEX_WEB_SERVICE.CLOBBASE642BLOB CONVERTS INCORRECTLY.

2 comments:

koloo kumo said...

Dimitri,
I am in the process of doing the same upgrade for apex 4.2.4 to x.5 with listener on red hat server and ive got the patch #17966818 but i dont know why also we need patch#18609856? what is the problem if i dont apply patch#18609856?

regards,
Koloo

Dimitri Gielis said...

There's already a new patch set available 4.2.6, which includes the other patch, so I would go with that.